Product Support => Fence Builder Pro => : Craig H November 04, 2016, 10:11:26 AM

: Error message
: Craig H November 04, 2016, 10:11:26 AM
Hi Guys,

Can someone help me resolve why I keep getting this message....I cannot get it to compile at all. It was working 5 months ago when I did my last scenery, but now it wont work at all.
: Re: Error message
: gadgets November 05, 2016, 09:09:18 PM
I am travelling at the moment and unable to provide investigative support.  I will be home mid next week.  If you are still having difficulty, please post again.

In the meantime, please be sure the destination folder you specified exists.

: Re: Error message
: Craig H November 05, 2016, 10:30:41 PM
Thanks Don. I will check as you mention, and post again later next week.

: Re: Error message
: Craig H November 05, 2016, 11:46:17 PM
By looking at the image, it appears the .xml file is in the folder FB is looking for. Not sure whats causing the issue.
: Re: Error message
: Craig H November 09, 2016, 11:29:33 AM
Just following up again Don as you requested mid week.....I am still having issues with the error. The destination folder does exist as far as I can see, but still wont compile.

Just FYI...my order number for FBP is  1288481 16th April 2015.
: Re: Error message
: gadgets November 10, 2016, 10:27:07 PM
Back home now, Craig.  This message is initiated by the compiler control code as a result of an exception thrown during initiation of the compile process.  Consequently, I suspect the message refers to the compiler .exe, not the XML file specified in the message header.

Are you sure the FSX compiler is available and located where you think it is (and have told FBP)?


: Re: Error message
: Craig H November 11, 2016, 04:03:13 AM
Thanks for your reply Don.

Where in FBP can I check the location of the complier.exe ?  Ive looked around in all the usual places and cannot find it. The complier is in the SDK of FSX. I have also copied it to the FBP  folder and tried to compile from there, with the same result. How do I tell FBP where the complier file is?

Should I re-install and re set the location so FBP knows?

Here is my FBP.ini file.

Path_FSX_Compiler=G:\Microsoft Flight Simulator X\Program Fles\SDK\SDK\Environment Kit\BGL Compiler SDK
: Re: Error message
: gadgets November 11, 2016, 04:56:28 PM
There is no need to re-install either FBP, FSX or the SDK.

The question is, is the compiler.exe still where you (at some point) told FBP (i.e., in the folder located at the path specified in the Path_FSX_Compiler entry of FBP.ini)?  If not, that's the problem.  So, the first step is to verify that path is still valid.  The file you are looking for is BglComp.exe.

If the compiler is not there, the simplest way to fix this is to close FBP and delete that line in FBP.ini.  The next time you attempt to compile for FSX, FBP should ask you to locate the compiler.  (Unlike FS9, Microsoft's FSX SDK license terms do not allow me to distribute the FSX compiler with FBP.)

: Re: Error message
: Craig H November 12, 2016, 06:20:20 AM
Thanks Don. here's my update.

I checked the path, and it seems that it has one too many "SDK" folders in the path (as highlighted in attachment). I deleted that line in FBP.ini. It didnt ask me to locate the compiler when I tried to compile a new project like it should have. I got the same error message with that attempt to compile. I checked  the ini file again, and it had reverted back to the same path as in that attachment, even after deleting that path line and trying to compile again. I tried just deleting one of the SDK words in the path line, and got the same message trying to compile. Again it reverted creating the same path in the ini file for a third time.

So in short -
tried removing the path line  - didnt ask for location of compiler when restarting a compile - same error
Checked ini file and the same path line was back in the ini file again - tried compile - same error
removed one instance of the "SDK" wording in ini file and tried to compile - same error. ( as highhlighted in attachment)

So, I tried several variations of what you suggested, with no success. Apart from the one duplication of the "SDK" letters/folder in the compiler location path in the "ini" file, the path seems to be correct in my attachment. By removing one off them, it should work????? It seems no matter what I change for the path file for the compiler to, it still goes back to the one in the attachment.

Whats next Don? ;)

: Re: Error message
: gadgets November 12, 2016, 05:08:27 PM
Chris, if you have deleted that line and saved the file with FBP NOT running, I have no idea why the old value is preserved.  The only place the compiler path is saved (that I am aware of) is in that file.

Two suggestions:
: Re: Error message
: Craig H November 13, 2016, 05:56:35 AM
Hi Don,

Tried both of your suggestions and no luck It just keeps putting the same path line back in the ini file.

Now, if I drag the .xml file for the project across onto the bgl compiler.exe file, I can manage to get a bgl compiled, but cant see the fences in fsx. I can move the bgl to my new scenery\scenery folder, then restarted fsx. It updates the scenery database, etc, but the fences still dont show. Im not sure creating the bgl this way works, or where the matching textures go to when the bgl is created. Maybe this is a workaround but I need to find the matching textures for the newly created bgl.

Is there something in the registry that I need to change? Any ideas?
: Re: Error message
: gadgets November 13, 2016, 06:17:16 PM
Craig, since no one else has, to my recollection, reported such a problem, it would seem to be due to something in your system configuration.  The .ini file is the only source of "knowledge" FBP has as to the location of the compiler.  (The FSX compiler is not registered in the system registry and, in any event could be located anywhere.)  If you delete FenceBuilderPro.ini when FBP is NOT running, that knowledge is gone and FBP's only alternative is to ask you where is the FSX compiler (when you attempt to compile) and, before then, save the .ini file without the path. Is the .ini file (which, according to your reports, will still hold the errant path) datestamp current?  If not, that suggests a configuration issue.

My second suggestion would not have affected the .ini file.  What it should have done is place the compiler where FBP for whatever reason thinks it is - and you should have been able to compile.

In your initial post you indicated you had no such difficulty 5 months ago.  What have you done to your system since?  Did you move the SDK or move/re-install FBP.  If FBP has not been adversely affected by something else during that period, all should be well.

As to a manual procedure, copying the .bgl to a scenery folder and all the corresponding textures into its companion texture folder is all that should be necessary if no special circumstances.  However, if the problem were missing textures, you would see a black fence.

: Re: Error message
: Craig H November 14, 2016, 12:10:37 PM
Hi Don,

Before you replied, I uninstalled FBP and re installed fresh. I created a brand new project, and same result. 

To your questions - The date stamp is the current date and time. I deleted the ini file and tried to compile again, then checked the date stamp and it is current. The ini file I deleted was also current but the time stamp was a few minutes earlier. Even with a fresh install, it still didnt ask me for the location of the compiler. The compiler file is in the correct place...the default location in the FSX SDK.

Ive done 3 or 4 scenery's now, and the last one I did had the same issue, but it was flat anyway, so I just did the fences manually. At that time I did uninstall, and reinstall, but the error was the same, so I just put it in the "too hard basket" until now. My last full install of FSX was in January this year on a new HDD, and the last time FBP compiled correctly was in May. There have been no changes that should effect it after that.

The manual process should work, but in the folders I can only see the MDL files and no texture files, hence nothing shows in FSX, not even the black fence. I can move the created bgl to the folder I want, just not the textures as I cant find them anywhere within the project.

I agree that it may be something in my system. I am aware of one other guy at the OZX forums who has the same issue as me, but i dont think he has done anything about it. I might bsee if he can chime in on this thread if you like.

I am stumped.  I cant understand why it wouldnt be asking me for the compiler location upon deletion of the ini file?????...or a full re install of FBP.

: Re: Error message
: TreeTops November 14, 2016, 12:20:40 PM
Hi Don,
I am the guy Craig wrote about every who has the same issue. I had been using FBP a little over the years but this year had the problem. This issue pre-dates Windows 10 so that's not the issue.
: Re: Error message
: gadgets November 14, 2016, 06:12:22 PM
After further testing I have now been able to repeat the problem you are experiencing.  "E:\SDK\SDK\Environment Kit\BGL Compiler SDK" is the path to the compiler on my development system. I therefore suspect the problem is due to me having omitted to deleting some test code prior to release. 

The suggestion I made a couple days ago, i.e., setting up a folder at the end of that persistent path containing the contents of the Compiler SDK should provide an workaround - because FBP will then find the compiler where its noted to be in the .ini file.

My last full install of FSX was in January this year on a new HDD, and the last time FBP compiled correctly was in May. There have been no changes that should effect it after that.
Obviously, something triggered the change.  I suspect that test code is buried in some function that you had never used before May but have used since.  Amazing that it took over 6 years and the introduction of Win 10 for the issue to be discovered!

The manual process should work, but in the folders I can only see the MDL files and no texture files, hence nothing shows in FSX, not even the black fence.
Assuming the project parameters actually generate a visible fence, and that you selected the correct .bgl (which, after a manual compile probably would be in the same folder as the .XML file), if there were no black fences, then the absence of textures  are not the issue.  You would have had to obtain the textures from the FBP\Textures folder since the required textures will not have been transferred to the project folder because the compile process did not run to completion.

I trust the workaround will allow you to continue.

: Re: Error message
: Craig H November 14, 2016, 09:39:54 PM
I away for work today and tomorrow, so I will check again when I get home. Treetops - Try Dons suggestion and see how you go.
: Re: Error message
: Craig H November 16, 2016, 11:13:29 AM
Hi Don,

Unfortunately still no luck mate.

See my image attached with the additional folder created and the contents of the bgl compiler dumped in it, the the line changed in the ini file? Is that what you meant?

I did a compile and got the error with the modified path file.  When I checked the ini file afterwards, it had reverted to the original path. Even tried deleting the ini file and starting again, and same error, and same path comes back in the ini file.

I did manage to get a fence to show in the test file when I moved the textures into my texture folder in my new scenery. I need to test if this theory works over uneven ground, as I tried it on a runway which was level.
: Re: Error message
: gadgets November 16, 2016, 04:11:34 PM
Craig, you are not paying attention.  The folder you set up does not have the same path as in aifp.ini.  (note 2 "SDK"s).  Setting up this new folder will not affect the aifp.ini file; it simply places the compiler to comply with  aifp.ini.

: Re: Error message
: Craig H November 16, 2016, 09:48:47 PM
Sorry Don....didnt fully understand you...been a  big few days with work.. I ve got it now. I will check it. The manual method is my fall back plan.
: Re: Error message
: Craig H November 17, 2016, 10:59:04 AM
Hi Don,

Many thanks for your help mate. I now have it working very well. Hopefully Trev (Treetops) can get his working as well.

SimplePortal 2.3.6 © 2008-2014, SimplePortal