Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Craig H

Pages: [1]
1
Fence Builder Pro / Re: Error message
« on: November 17, 2016, 10:59:04 AM »
Hi Don,

Many thanks for your help mate. I now have it working very well. Hopefully Trev (Treetops) can get his working as well.

Regards
Craig

2
Fence Builder Pro / Re: Error message
« on: November 16, 2016, 09:48:47 PM »
Sorry Don....didnt fully understand you...been a  big few days with work.. I ve got it now. I will check it. The manual method is my fall back plan.

3
Fence Builder Pro / Re: Error message
« on: November 16, 2016, 11:13:29 AM »
Hi Don,

Unfortunately still no luck mate.

See my image attached with the additional folder created and the contents of the bgl compiler dumped in it, the the line changed in the ini file? Is that what you meant?

I did a compile and got the error with the modified path file.  When I checked the ini file afterwards, it had reverted to the original path. Even tried deleting the ini file and starting again, and same error, and same path comes back in the ini file.

I did manage to get a fence to show in the test file when I moved the textures into my texture folder in my new scenery. I need to test if this theory works over uneven ground, as I tried it on a runway which was level.

4
Fence Builder Pro / Re: Error message
« on: November 14, 2016, 09:39:54 PM »
I away for work today and tomorrow, so I will check again when I get home. Treetops - Try Dons suggestion and see how you go.

5
Fence Builder Pro / Re: Error message
« on: November 14, 2016, 12:10:37 PM »
Hi Don,

Before you replied, I uninstalled FBP and re installed fresh. I created a brand new project, and same result. 

To your questions - The date stamp is the current date and time. I deleted the ini file and tried to compile again, then checked the date stamp and it is current. The ini file I deleted was also current but the time stamp was a few minutes earlier. Even with a fresh install, it still didnt ask me for the location of the compiler. The compiler file is in the correct place...the default location in the FSX SDK.

Ive done 3 or 4 scenery's now, and the last one I did had the same issue, but it was flat anyway, so I just did the fences manually. At that time I did uninstall, and reinstall, but the error was the same, so I just put it in the "too hard basket" until now. My last full install of FSX was in January this year on a new HDD, and the last time FBP compiled correctly was in May. There have been no changes that should effect it after that.

The manual process should work, but in the folders I can only see the MDL files and no texture files, hence nothing shows in FSX, not even the black fence. I can move the created bgl to the folder I want, just not the textures as I cant find them anywhere within the project.

I agree that it may be something in my system. I am aware of one other guy at the OZX forums who has the same issue as me, but i dont think he has done anything about it. I might bsee if he can chime in on this thread if you like.

I am stumped.  I cant understand why it wouldnt be asking me for the compiler location upon deletion of the ini file?????...or a full re install of FBP.

Craig

6
Fence Builder Pro / Re: Error message
« on: November 13, 2016, 05:56:35 AM »
Hi Don,

Tried both of your suggestions and no luck It just keeps putting the same path line back in the ini file.

Now, if I drag the .xml file for the project across onto the bgl compiler.exe file, I can manage to get a bgl compiled, but cant see the fences in fsx. I can move the bgl to my new scenery\scenery folder, then restarted fsx. It updates the scenery database, etc, but the fences still dont show. Im not sure creating the bgl this way works, or where the matching textures go to when the bgl is created. Maybe this is a workaround but I need to find the matching textures for the newly created bgl.

Is there something in the registry that I need to change? Any ideas?

7
Fence Builder Pro / Re: Error message
« on: November 12, 2016, 06:20:20 AM »
Thanks Don. here's my update.

I checked the path, and it seems that it has one too many "SDK" folders in the path (as highlighted in attachment). I deleted that line in FBP.ini. It didnt ask me to locate the compiler when I tried to compile a new project like it should have. I got the same error message with that attempt to compile. I checked  the ini file again, and it had reverted back to the same path as in that attachment, even after deleting that path line and trying to compile again. I tried just deleting one of the SDK words in the path line, and got the same message trying to compile. Again it reverted creating the same path in the ini file for a third time.

So in short -
tried removing the path line  - didnt ask for location of compiler when restarting a compile - same error
Checked ini file and the same path line was back in the ini file again - tried compile - same error
removed one instance of the "SDK" wording in ini file and tried to compile - same error. ( as highhlighted in attachment)

So, I tried several variations of what you suggested, with no success. Apart from the one duplication of the "SDK" letters/folder in the compiler location path in the "ini" file, the path seems to be correct in my attachment. By removing one off them, it should work????? It seems no matter what I change for the path file for the compiler to, it still goes back to the one in the attachment.

Whats next Don? ;)


8
Fence Builder Pro / Re: Error message
« on: November 11, 2016, 04:03:13 AM »
Thanks for your reply Don.

Where in FBP can I check the location of the complier.exe ?  Ive looked around in all the usual places and cannot find it. The complier is in the SDK of FSX. I have also copied it to the FBP  folder and tried to compile from there, with the same result. How do I tell FBP where the complier file is?

Should I re-install and re set the location so FBP knows?

Here is my FBP.ini file.

Project=test3
AutoSave=False
AutoSaveTime=10
AutoPosition=False
AutoUpdates=False
Path_FSX_Compiler=G:\Microsoft Flight Simulator X\Program Fles\SDK\SDK\Environment Kit\BGL Compiler SDK
SaveTextData=False
CloseDialogs=False
LastChecked_Version=*
LastChecked_Message=
PauseAfterSlew=False
MinSelectSize=5
MouseBreakoutDist=3
PlanViewDisplayMode=0
ProfileViewDisplayMode=0
SuppressConfirmationQueries=False
KeepViews=False
PlanViewLocation=0,0
PlanViewSize=0,0
ProfileLocation=0,0
ProfileSize=0,0

9
Fence Builder Pro / Re: Error message
« on: November 09, 2016, 11:29:33 AM »
Just following up again Don as you requested mid week.....I am still having issues with the error. The destination folder does exist as far as I can see, but still wont compile.

Just FYI...my order number for FBP is  1288481 16th April 2015.

10
Fence Builder Pro / Re: Error message
« on: November 05, 2016, 11:46:17 PM »
By looking at the image, it appears the .xml file is in the folder FB is looking for. Not sure whats causing the issue.

11
Fence Builder Pro / Re: Error message
« on: November 05, 2016, 10:30:41 PM »
Thanks Don. I will check as you mention, and post again later next week.

Craig

12
Fence Builder Pro / Error message
« on: November 04, 2016, 10:11:26 AM »
Hi Guys,

Can someone help me resolve why I keep getting this message....I cannot get it to compile at all. It was working 5 months ago when I did my last scenery, but now it wont work at all.

Pages: [1]